TOsとは? わかりやすく解説

tos

別表記:tosツイ、@tos、トス、トスツイ

「tos」とは、Twitterで使われる表記方法のひとつでコメントの最初に「@tos」とつけて書くことで特定のアカウント宛てのメッセージではない投稿のことを意味する表現のこと。

もともとは、2008年頃から@tosアカウントがTwitterにて凍結されているユーザー名であるために、コメントに@tosと記載しても誰かに通知がいくわけではないことを想定して主に日本で用いられるようになった表現方法である。
また、Twitterの利用規約であるのページが、「https://twitter.com/ja/tos 」であることなどから、長らく@tosというアカウントは公式によって取得ができないようにされているアカウントだと考える人が多かった。
一方で、利用規約のページのURLは単純に「Terms of Service」の頭文字からとられてもので、コメントの際に通知を届かないようにするという挙動とは関係のないものであり、また、2022年2月には、@tosアカウントの凍結が解除されたことで、Twitter側の公式見解としても特別な機能を持たせたアカウントではないことが明言されている。

「tos」とは・「tos」の意味

「tos」とは、ツイッターで使用される用語のひとつであり、つぶやきの投稿を、フォロワーのタイムラインに表示させないようにするために使用される。特定のアカウント名「tos」が元になっていて、言葉自体に意味はない。あくまでも、ツイッターを快適に使用するために用いられる、文字の羅列である。ツイッターでは、何らかのつぶやきを投稿した場合、自らのアカウントをフォローしている人、フォロワーのタイムライン画面に表示されるのが基本だ。ただ、ツイッターユーザーの中には、あまりフォロワーの目に触れさせたくないつぶやきを投稿するという人もいる。そのような時に使用するのが、tosである。

tosとは、ツイッター上で長い間凍結されていたアカウント名である。ツイッターには、特定のアカウントに返信をする、リプライを送る機能が備わっている。しかし、何らかの理由で凍結され、利用不可能になっているアカウントに対してリプライを送った場合、そのリプライの内容はフォロワーには表示されない。つまり、凍結されているtosという名前のアカウントに、あえてリプライを送る形で投稿することで、フォロワーのタイムラインにつぶやきが表示されるのを防げる。

tosアカウントにリプライを送る形でつぶやきを投稿した場合、その投稿がフォロワーから完全に見えなくなるわけではない。フォロワーがツイッターのプロフィール画面にアクセスした場合、投稿は全て見える。よって、絶対にフォロワーに見せたくないつぶやきを投稿するためには使用されない。見られても問題はないが、フォロワーにはあまり関係ないつぶやきを投稿する際に、tosが使用されることが多い。フォロワーのタイムラインに無関係な投稿を表示させ、迷惑をかけてしまうことを防ぐ形だ。

同様の機能は、凍結されているアカウントであれば、tos以外でも使用できる。その中でtosという言葉が選ばれたのは、文字数の少なさがひとつの理由である。ツイッターには、ひとつのつぶやきに対して、140文字という制限が設けられている。さらに、2017年までは、リプライをする相手の名前も、文字数に含まれていた。そのため、なるべく文字数が少なく済むよう、3文字でのリプライが可能なtosが選ばれた形だ。そして、フォロワーのタイムラインに、自らの投稿を表示させない方法として、tosを使用することが定着した。その結果、2017年以降、リプライ名が文字数制限に換算されなくなってからも、tosが使用されることが多い。

また、ツイッターを運営するtwitter社が、tosのアカウントを保有するという話が出回ったことも、tosが使用される理由である。個人が保有するアカウントは、いつ凍結が解除されるか不明瞭である。もし、凍結が解除されれば、フォロワーのタイムラインにつぶやきが表示されてしまう。それに対して、twitter社が保有している凍結アカウントであれば、凍結解除されるリスクが低いという理由で、tosが選ばれた。しかし、結果的に、twitter社がtosアカウントを管理しているという事実はなく、あくまでも噂であることが判明している。

ツイッターでは、攻撃的なつぶやきをしたり、他者に対する嫌がらせをしたりしたアカウントが凍結される。ただ、tosアカウントが凍結された理由は明らかにされていない。そのため、ユーザーの中には、「tosの凍結 なぜ?」という疑問を持ちながら、使用している人も少なくない。

tosは、it業界では、専門用語「type of service」の略称として使用される。コンピュータ同士がデータをやり取りする際に使う用語である。ネットワークを用いたデータのやり取りでは、ipパケットという、データを入れる箱を使用する。データは、ipパケットに入った状態で送信される。そして、ipパケットには、制御情報などを記載したipヘッダが取り付けられる。そのipヘッダの一部が、tosである。tosは、ipヘッダにおけるフィールドであり、様々な目的で使われる。

tosの使い道としては、qosという、ネットワークに欠かせない重要な技術が代表的である。qosは、ネットワークにおいて、重要な情報を優先的に処理するための技術だ。優先度が高い情報を先に処理することで、ネットワーク通信が安定する。その優先度を決める際に、tosのフィールドが用いられる。

「tos」の熟語・言い回し

Tos復活とは


Tos復活とは、凍結されていたツイッターのtosアカウントが、凍結解除されることである。tosは、twitter社が管理する凍結アカウントではなく、個人が所有するものである。そのため、いつ凍結解除されてもおかしくはない。そして、2022年に、実際に凍結が解除された。その結果、tosを使用しても、確実につぶやきを非表示にできるとは限らなくなった。

@Tosとは


@Tosとは、tosアカウントにリプライを送るために使用する文字の羅列である。ツイッターでは、「@」の後に、アカウント名を付けることで、リプライを送ることができる。そのため、@tosは、tosを用いてつぶやきを非表示にするために欠かせない。

@tosさんとは


@tosさんとは、tosアカウントに敬称を付けたものだ。tosのアカウントは、誰かが保有している可能性が高い。そして、自らのつぶやきを非表示にするために、使用させてもらっているということで、「さん」付けするユーザーが大勢いる。アカウントの保有者に、敬意を示している形だ。

TOSツイートとは


TOSツイートとは、tosにリプライを送る形で、フォロワーのタイムラインに表示されないようにしたつぶやきのことである。また、自らのタイムラインに表示される迷惑なつぶやきを、TOSツイートと表現することもある。TOSツイートにして、タイムラインに表示されないようにするべきつぶやきだ、という表現だ。

マシュマロ tosとは


マシュマロ tosとは、マシュマロで送られてきた質問に対して、tosへのリプライ形式で返答することである。ツイッターでは、マシュマロという匿名メッセージサービスを使用することができる。マシュマロでは、何らかの質問が投げかけられることが多い。その質問への回答は、つぶやき機能を使用するのが基本だ。その際に、tosへのリプライを使って返信するのが、マシュマロ tosである。マシュマロの質問に対する回答は、質問をしてきた相手にのみ見えれば良いため、フォロワーの迷惑にならないよう、tosを使用して非表示にする形だ。そして、質問者には、プロフィールから回答を見られることを伝える。

「tos」の使い方・例文

ツイッター上でtosを使用する際には、つぶやきの先頭に「@tos」という文字を置く。そうすることで、つぶやきがtosへのリプライになる。例文にすると、「@tos 今日の夕食はあまり美味しくはなかった」「@tos この時間帯はカラスの鳴き声がうるさい」といった形だ。先頭に@tosがなければ、tosにリプライを送ったことにならず、フォロワーのタイムラインに表示されてしまうので注意が必要である。

そして、「@tos ○○神社の近くにあった駄菓子屋を覚えている人がいたら嬉しい」「@tos ○○大学の試験内容がわかる人はいないだろうか」のように、フォロワーにあまり関係ない、プライベートに関することで使用する場合も多い。

また、ツイッターを使用して、ゲームの協力や、グッズの交換を持ちかける際にも使用できる。その場合は、「@tos 誰か協力プレイをしませんか #○○ゲーム」「@tos 今回のイベントのグッズ交換をお願いします #○○グッズ」のような例文になる。そうして、ハッシュタグや検索ボックスから投稿を見つけた人とやり取りをしていく。

さらに、フォロワー以外の人との繋がりを作るために、ハッシュタグのみを記載するパターンもある。その場合の使い方は、「@tos #筋トレが好き #ジョギングが趣味」「@tos #映画好きの人と繋がりたい #ジョニー・デップ推し」といった形になる。

tosをit用語として使用する場合、ipパケットやipヘッダにおけるフィールドを指す。そして、「tosフィールド」という用語として使用することも珍しくはない。例文にすると「このネットワーク異常は、tosの扱いが間違っていることが原因だろう」「ネットワークを安定させるために、tosフィールドの設定を変更する」といった形だ。

Tos

名前 トス

TOS

出典: フリー百科事典『ウィキペディア(Wikipedia)』 (2023/09/15 05:18 UTC 版)

Tos, ToS, TOS

Tos

ToS

TOS

正式名称

  • ティー・オー・エス - かつて存在したウェブサイト管理会社、魔法のiらんどが1989年から2006年まで名乗っていた社名。NTTデータビジネスシステムズ [1]の前身。
    • ティー・オー・エス - かつて存在した上記会社の子会社。KADOKAWAの前身のひとつ。

コード

略称

一般名詞
地名
企業
学会
商標等
作品の名称

Type of Service

(TOs から転送)

出典: フリー百科事典『ウィキペディア(Wikipedia)』 (2022/10/06 14:08 UTC 版)

Type of Service(タイプ・オブ・サービス、ToS、サービス種別)フィールドは、IPv4ヘッダの先頭から2バイト目(8 - 15ビット目)である。このフィールドには長年にわたって様々な目的が割り当てられ、5つのRFC[1]にそれぞれ異なる方法で定義されている

再定義される以前は、ToSフィールドはデータグラムの優先順位を指定し、低遅延、高スループット、または信頼性の高いサービスのための経路を要求するために使用されていた。ToS値に基づいて、パケットは優先送信キューに入れられ[2]、あるいは適切なレイテンシ、スループット、または信頼性により転送されることになる。実際には、この目的でのToSフィールドの利用は、米国国防総省のネットワーク以外では広く使用されていない。しかしながら、多くの実験的、研究的、展開的な研究はこの8ビットをどのように利用するかに焦点を合わせており、その結果が現在のDSフィールドの定義になっている。

再定義後のToSフィールドは、6ビットのDifferentiated Services Code Point(DSCP)フィールド[3]と2ビットのExplicit Congestion Notification(ECN)フィールド[4]から構成される8ビットのDS(differentiated services)フィールドである。Differentiated ServicesはToSとやや後方互換性があるが、ECNにはない。このDSフィールドのフォーマットは、IPv6のTraffic Classフィールドにも使用されている。

歴史

IPヘッダのToSフィールドは、元々 RFC 791 で定義されたもので、それ以来IP優先順位とToSとして解釈されてきた。この定義は、主にメッセージ優先順位を定義する米国国防総省仕様JANAP-128から派生したものである。これは、各IPパケットに優先順位を割り当てるためのメカニズム、および高スループット、高信頼性、低遅延などの特定の処理を要求するためのメカニズムを定義している。 RFC1349 では、Monetary Costビットが導入された(このビットは、RFC 791では将来の使用のために予約されていた)。 RFC 1583 (OSPFv2)のセクション2.4で、ToS対応ルーティング方式が導入された。

実際には、このフィールドのIP優先順位の部分だけが米国DoDネットワークの外で使用されたことがある。IP優先順位フィールドの値が高いほど、IPパケットの優先順位が高くなる。米国DoDネットワークの中には、海洋ケーブル経路と衛星通信(SATCOM)経路の間の経路選択(両方の経路が存在する場合)に遅延ビットを使用したものもあった。作者がその起草時にDiffServの取り組みを知っていたこともあり、IPv6にはIPv4のような伝統的なToSフィールドがなかった( RFC 2460 Section 7)。

RFC 2474 では、このフィールド全体の定義が変更された。現在はDS(Differentiated Services、DiffServ)フィールドと呼ばれており、上位6ビットにはDSCP(Differentiated Services Code Point)と呼ばれる値が含まれている。DSの上位3ビットは、IP優先順位との互換性を維持する。RFC 3168 以降、残りの2ビット(最下位2ビット)はExplicit Congestion Notification(ECN)に使用される。

割当て

優先順位とToS

RFC 791 では、Type of Serviceフィールドは次のように定義されていた。

0 1 2 3 4 5 6 7
優先順位 Type of Service 未使用(0)

優先順位(Precedence)は先頭3ビットのフィールドであり、この数値の高いパケットを他のパケットよりも重要なものとして扱う。ルータが輻輳していて、いくつかのパケットを破棄する必要がある場合は、優先順位が最も低いパケットが最初に破棄される。優先順位フィールドはIPv4の一部であるが、使用されることはなかった。

RFC 1349 で低コスト(lowcost)フィールドが追加され、ToSの4つのビットの役割が以下のようになった。

0 1 2 3 4 5 6 7
(優先順位) 低遅延 スループット 信頼性 低コスト 未使用(0)

ここでの命名は、Unixオペレーティングシステムの規約に従う[5]。 RFC 1349 および RFC 1060 では、アプリケーションのデフォルト値として同時に使用される1ビットの例のみを示しているが、 RFC 791 では、3つのビットのうち最大2つを名目上設定する必要があると述べている。そのような用途の1つがmod_iptosにある[6]。

最後の3ビットはRFC 2474以前に多くの定義を経ているため(下記参照)、文書化と実装の際に混乱し矛盾を来す可能性がある。

DSCPとECN

RFC 2474 (1998年12月発表)ではDSフィールドの最初の6ビットをDifferentiated Services Code Point(DSCP)用に予約し、RFC 3168では後ろの2ビットをExplicit Congestion Notification(英語版)用に予約した。

0 1 2 3 4 5 6 7
DSCP ECN

DSCPは、定義した各値に名前を付けるクラスセレクタ(CS)を定義しており、先頭の3ビットは従前の仕様のIP優先順位を反映している。

DSCP/IP優先順位変換テーブル
DSCP名 DS Fieldの値(十進数) IP優先順位
CS0 0 0: Best Effort
CS1, AF11-13 8,10,12,14 1: Priority
CS2, AF21-23 16,18,20,22 2: Immediate
CS3, AF31-33 24,26,28,30 3: Flash - mainly used for voice signaling
CS4, AF41-43 32,34,36,38 4: Flash Override
CS5, EF 40,46 5: Critical - mainly used for voice RTP
CS6 48 6: Internetwork Control
CS7 56 7: Network Control

DSCPの命名法:

CS
クラスセレクタ (RFC 2474)
AFxy
Assured Forwarding (x=class, y=drop precedence) (RFC 2597)
EF
Expedited Forwarding (RFC 3246)

上記の表では、ToSフィールド全体の値に対して個々の値が書き出されている。

DSCP/ToS/IP優先順位変換テーブル
DSCP値 ToS値 IP優先順位
0 0 0
8 32 1
10 40 1
14 56 1
18 72 2
22 88 2
24 96 3
28 112 3
34 136 4
36 144 4
38 152 4
40 160 5
46 184 5
48 192 6
56 224 7

注:上の表では、ToSは十進数で表示されている。多くのルータはToSを16進形式で表す。

例えば、IP優先順位が1、すなわち2進数で0b001の場合、未使用の5ビットがゼロであると仮定すると、ToSフィールド全体は001 00000になる。これを001000 00と解釈すると、先頭5ビットの001000 = 8がDSCP値となる。

脚注

  1. ^ RFC 791 、 RFC 1122 、 RFC 1349 、 RFC 2474 、 RFC 3168 の5つ。ToSフィールドの歴史については RFC 3168 のsection 22を参照。
  2. ^ http://www.tldp.org/HOWTO/Adv-Routing-HOWTO/lartc.qdisc.classless.html Linux Advanced Routing & Traffic Control
  3. ^ RFC 3260 Section 4
  4. ^ RFC 3168 Section 5
  5. ^ “openbsd/src:sys/netinet/ip.h” (英語). GitHub. 2018年10月10日閲覧。
  6. ^ “mod_iptos.c (mod_iptos 1.0)”. 2018年10月10日時点のオリジナルよりアーカイブ。2018年10月10日閲覧。

参考文献

  • John Evans, Clarence Filsfils (2007). Deploying IP and MPLS QoS for Multiservice Networks: Theory and Practice. Morgan Kaufmann. ISBN 978-0123705495 

関連項目

外部リンク



英和和英テキスト翻訳

英語⇒日本語日本語⇒英語

辞書ショートカット

すべての辞書の索引

「TOs」の関連用語

TOsのお隣キーワード
検索ランキング

   

英語⇒日本語
日本語⇒英語
   



TOsのページの著作権

   
実用日本語表現辞典実用日本語表現辞典
Copyright © 2026実用日本語表現辞典 All Rights Reserved.
アライドテレシス株式会社アライドテレシス株式会社
Copyright(c)2026 Allied Telesis K.K. All Rights Reserved.
日外アソシエーツ株式会社日外アソシエーツ株式会社
Copyright (C) 1994- Nichigai Associates, Inc., All rights reserved.
ウィキペディアウィキペディア
All text is available under the terms of the GNU Free Documentation License.
この記事は、ウィキペディアのTOS (改訂履歴)、Type of Service (改訂履歴)の記事を複製、再配布したものにあたり、GNU Free Documentation Licenseというライセンスの下で提供されています。 Weblio辞書に掲載されているウィキペディアの記事も、全てGNU Free Documentation Licenseの元に提供されております。

©2026 GRAS Group, Inc.RSS