SmtpStatusCode 列挙体とは? わかりやすく解説

SmtpStatusCode 列挙体

メモ : この列挙体は、.NET Framework version 2.0 で新しく追加されたものです。

電子メールの送信結果を、SmtpClient クラスを使用して指定します。

名前空間: System.Net.Mail
アセンブリ: System (system.dll 内)
構文構文

Dim instance As SmtpStatusCode
public enum SmtpStatusCode
public enum class SmtpStatusCode
public enum SmtpStatusCode
public enum SmtpStatusCode
メンバメンバ
 メンバ名説明
BadCommandSequenceコマンドが不正な順序で送信されました。 
CannotVerifyUserWillAttemptDelivery指定したユーザーはローカルではありませんが、受信側の SMTP サービスはそのメッセージを受け入れ、配信を試みました。このステータス コードは、RFC 1123 (http://www.ietf.org を参照) で定義されています。 
ClientNotPermittedクライアントが認証されなかったか、指定した SMTP ホストを使用したメールの送信が許可されていません。 
CommandNotImplementedSMTP サービスは指定したコマンドを実装していません。 
CommandParameterNotImplementedSMTP サービスは指定したコマンド パラメータを実装していません。 
CommandUnrecognizedSMTP サービスは指定したコマンドを認識できません。 
ExceededStorageAllocationメッセージが大きすぎて、送信先のメールボックスに格納できません。 
GeneralFailureトランザクションを発行できませんでした。指定した SMTP ホストが見つからない場合にこのエラーが発生します。 
HelpMessageサービスによってヘルプ メッセージが返されました。 
InsufficientStorageSMTP サービスには、要求を完了するために必要な容量のストレージがありません。 
LocalErrorInProcessingSMTP サービスは要求を完了できません。このエラーは、クライアントの IP アドレスが解決できない (つまり、逆引き参照の失敗) 場合に発生します。クライアントのドメインが、第三者中継や迷惑メール (SPAM) の送信元として識別されている場合にも、このエラーが発生します。詳細については、RFC 2505 (http://www.ietf.org) を参照してください。 
MailboxBusy送信先のメールボックスが使用中です。 
MailboxNameNotAllowed送信先のメールボックスの指定に使用した構文が正しくありません。 
MailboxUnavailable送信先のメールボックスが見つからなかったかアクセスできませんでした。 
MustIssueStartTlsFirstSMTP サーバーが TLS 接続のみを受け入れるように構成されており、SMTP クライアントが非 TLS 接続を使用して接続しようとしています。これを解決するには、そのユーザーについては、SMTP クライアントで EnableSsl=true を設定します。 
Ok電子メールは SMTP サービスに正常に送信されました。 
ServiceClosingTransmissionChannelSMTP サービスの伝送チャネルが閉じられています。 
ServiceNotAvailableSMTP サービスが利用できません。サーバーの伝送チャネルが閉じられています。 
ServiceReadySMTP サービスの準備が整っています。 
StartMailInputSMTP サービスは、電子メールの内容を受信できる状態です。 
SyntaxErrorコマンドまたはパラメータの指定に使用した構文が正しくありません。 
SystemStatusシステム ステータスまたはシステム ヘルプの応答です。 
TransactionFailedトランザクションが失敗しました。 
UserNotLocalTryAlternatePathユーザー メールボックスが受信側のサーバー上に配置されていません。提供されたアドレス情報を使用して再送信する必要があります。 
UserNotLocalWillForwardユーザー メールボックスが受信側のサーバー上に配置されていません。サーバーは電子メールを転送します。 
解説解説

SmtpStatusCode 列挙体の値は、SMTP (Simple Mail Transfer Protocol) サーバーから送付される応答のステータス値を指定します。SmtpException クラスと SmtpFailedRecipientsException クラスには、SmtpStatusCode の値を返す StatusCode プロパティが含まれます。

SMTP は、RFC 2821 (http://www.ietf.org を参照) で定義されています。

使用例使用例

SmtpException がスローされたときにコンソールにエラー メッセージを表示するコード例を次に示します。

public static void CreateMessageWithAttachment3(string
 server, string to)
{
    // Specify the file to be attached and sent.
    // This example assumes that a file named Data.xls exists in the
    // current working directory.
    string file = "data.xls";
    // Create a message and set up the recipients.
    MailMessage message = new MailMessage(
       "ReportMailer@contoso.com",
       to,
       "Quarterly data report",
       "See the attached spreadsheet.");

    // Create  the file attachment for this e-mail message.
    Attachment data = new Attachment("Qtr3.xls");
    // Add time stamp information for the file.
    ContentDisposition disposition = data.ContentDisposition;
    disposition.CreationDate = System.IO.File.GetCreationTime(file);
    disposition.ModificationDate = System.IO.File.GetLastWriteTime(file);
    disposition.ReadDate = System.IO.File.GetLastAccessTime(file);
    // Add the file attachment to this e-mail message.
    message.Attachments.Add(data);
    //Send the message.
    SmtpClient client = new SmtpClient(server);
    // Add credentials if the SMTP server requires them.
    client.Credentials = (ICredentialsByHost)CredentialCache.DefaultNetworkCredentials;
    // Notify user if an error occurs.
    try
    {
        client.Send(message);
    }
    catch (SmtpException e)
    {
        Console.WriteLine("Error: {0}", e.StatusCode);
    }
    finally
    {
        data.Dispose();
    }
}
プラットフォームプラットフォーム
バージョン情報バージョン情報
参照参照
関連項目
System.Net.Mail 名前空間



英和和英テキスト翻訳

英語⇒日本語日本語⇒英語

辞書ショートカット

すべての辞書の索引

「SmtpStatusCode 列挙体」の関連用語

SmtpStatusCode 列挙体のお隣キーワード
検索ランキング

   

英語⇒日本語
日本語⇒英語
   



SmtpStatusCode 列挙体のページの著作権

   
日本マイクロソフト株式会社日本マイクロソフト株式会社
© 2026 Microsoft.All rights reserved.

©2026 GRAS Group, Inc.RSS