マシンツーマシンとは? わかりやすく解説

Weblio 辞書 > 辞書・百科事典 > デジタル大辞泉 > マシンツーマシンの意味・解説 

マシン‐ツー‐マシン【machine to machine】

読み方:ましんつーましん

⇒エム‐ツー‐エム(M to M)


M2M

「IT用語辞典バイナリ」の他の用語
ネットワーク:  DQDB  プロトコル  LAN  M2M  モデム  NGN  ネットワーク

マシンツーマシン

出典: フリー百科事典『ウィキペディア(Wikipedia)』 (2025/09/14 21:54 UTC 版)

マシンツーマシン(英語: Machine-to-Machine、M2M)とは、コンピュータネットワークに繋がれた機械同士が人間を介在せずに相互に情報交換し、自動的に最適な制御が行われるシステムを指す。マシンツーマネジメント (Machine-to-Management)とも呼ばれ、モバイル通信の標準化団体である3GPPはマシンタイプコミュニケーション (Machine Type Communication)という名称で標準化を行っている[1]。

情報通信ネットワークと通信技術・通信機器の発達、およびセンサネットワーク技術や情報処理システムの高度化により初めて可能となるシステムで、ユビキタスコンピューティングの成果の一つである。通信機器が小型化され各種の装置に容易に組み込むことが可能になったこと、オンラインネットワークが国中の隅々まで張り巡らされたこと、さらには無線通信技術の発展などの多様な技術が M2M を支える土台となっている。

M2Mの主な活用分野

様々な分野で活用されている[2]。

  • 自然環境の監視
  • 見守り・ セキュリティ
  • 遠隔での使用状況等監視
  • 決済関係
  • 車両関係
  • 広告表示
  • インダストリー4.0

システム事例

戸建住宅などで使用されているプロパンガス供給装置(ガスボンベ)にセンサーを取り付け、ガス消費量をリアルタイムでガス会社に送る M2M システムのモデルを考えてみる。

ガス供給装置にガスの消費量を計測し、ガス会社のシステムへ自動送信する。これらの情報に基づき、ガス会社のシステムでは各供給装置のガスが無くなる時期を自動的に計算する。同時に近隣の供給装置からの情報も併せて計算し、最適の日程かつ配送ルートで供給装置の交換が出来るよう各配送所に情報を送る。

旧来の方法では、現場の経験と勘が頼りとなり根拠に乏しい面があり、供給装置内のガスが空になることを恐れて交換サイクルが早くなったり、残量が十分であっても近隣の供給装置を一括して交換する方法になりがちである。すなわち、供給装置の持ち帰りと充填作業が無駄に発生していることになる。M2M 型システムを導入することで、遠隔地にある情報を自動でリアルタイムに確認できるようになり、計算に基づく効率的な作業が可能となる。さらに、単なる供給装置交換の効率化にとどまらず、消費量が一定の計算値を超えている場合にはガス漏れの警報を出したり、他のネットワーク経由で近隣の火災情報が入った場合に遠隔操作でガスの供給を一時的に停止する等の処理の自動化も技術的に可能である。

ほかに、不法侵入者を感知して現場対応中でない最寄の警備員へ自動通報する防犯警報装置、自動販売機の在庫切れを検知して在庫の引き当て(発注)や配送ルートまで算出する装置など、M2M 型システムを利用できる。

諸国におけるM2Mサービス用電気通信番号の使用状況

諸国におけるM2Mサービス用電気通信番号の使用状況
国 M2M用番号 番号容量 指定数 M2M用番号帯
識別子 加入番号桁数 専用 備考
ドイツ 015 9 約10億 × 携帯電話番号を使用
イギリス 07 9 約8億 × 携帯電話番号を使用
フランス 0700 10 約100億 約5,000万 ○ 携帯電話番号を使用することは禁止
オランダ 097 9 約8億 約1億 ○ 携帯電話番号を使用することは禁止
スペイン 59 11 約1000億 約7450万 ○ 携帯電話番号を使用することは原則禁止
米国 5 9 数十億 約5,600万 × 非地理的番号(5XX)等を使用
日本 020 8 約8,000万 約2,270万 ○ 携帯電話番号を使用することは原則禁止
0200 10 100億

M2Mサービス用識別子の候補

M2Mサービス用識別子の候補(3GPP技術レポートTR22.988)
ソリューション 識別子 定義 体系 利用サービス例
現状の番号計画の継続利用 既存の番号長でのMSISDN ITU‐T勧告E.164 最大15桁の数字列 電話サービス
通信モジュール
番号計画の拡張 最大番号長15桁でのMSISDN ITU‐T勧告E.164 最大15桁の数字列
IMSI ITU‐T勧告E.212 最大15桁の数字列 携帯電話等でのSIMカード識別
その他の番号 必要に応じて定義
新識別子の導入 URI <任意の数字・文字列> WEBなど
SIP‐URI RFC3261 sip: <任意の数字・文字列>@<ドメイン形式> IP電話など
tel‐URI RFC3966 tel: <任意の数字列> IP電話など
FQDN STD13 <スキーム>:<任意の数字・文字列> WEBなど
NAI RFC4282 <任意の数字・文字列>@<ドメイン形式>
@以降を省略する場合あり
ネットワークでの端末等の認証
IPv4アドレス RFC791 32ビットのビット列 IPv4ネットワークでのルーティング
IPv6アドレス RFC2460 128ビットのビット列 IPv6ネットワークでのルーティング

M2Mサービス用の電気通信番号のオプション

M2Mサービス用の電気通信番号のオプション(ITU-T SG2)
オプション 番号 特徴
A 既存の移動通信番号帯 既に多くの番号で利用されており番号容量が小さい
規制面で、M2M用番号を異なる取り扱いとすることが困難
B 新しいE.164番号帯 新たな番号帯により番号容量を大きく確保することが可能
番号分析、規制要件、課金などの処理について、簡便な方法等を新しく採用することが可能
C 国際共有番号 複数の国で共通に使用可能
ITU-Tが番号の割当てを行い、申請者は適格性が必要
自国内通信でも国際コードが必要だが、M2Mでは問題とならない
D 網内番号 電気通信事業者のネットワークに閉じられた番号であり、事業者間の相互接続は不可
事業者が利用するに当たり、網内独自の仕様での展開が可能

脚注・参照

  1. ^ M2Mを取り巻く標準化動向 - NTTアドバンステクノロジ
  2. ^ 『資料5-4 IoT時代の電気通信番号に関する研究会報告書(案)』(プレスリリース)IoT時代の電気通信番号に関する研究会、2019年5月13日。https://www.soumu.go.jp/main_content/000618963.pdf。2019年5月21日閲覧。 


関連項目



英和和英テキスト翻訳

英語⇒日本語日本語⇒英語

辞書ショートカット

すべての辞書の索引

「マシンツーマシン」の関連用語

マシンツーマシンのお隣キーワード
検索ランキング

   

英語⇒日本語
日本語⇒英語
   



マシンツーマシンのページの著作権

   
デジタル大辞泉デジタル大辞泉
(C)Shogakukan Inc.
株式会社 小学館
IT用語辞典バイナリIT用語辞典バイナリ
Copyright © 2005-2026 Weblio 辞書 IT用語辞典バイナリさくいん。 この記事は、IT用語辞典バイナリの【M2M】の記事を利用しております。
ウィキペディアウィキペディア
All text is available under the terms of the GNU Free Documentation License.
この記事は、ウィキペディアのマシンツーマシン (改訂履歴)の記事を複製、再配布したものにあたり、GNU Free Documentation Licenseというライセンスの下で提供されています。 Weblio辞書に掲載されているウィキペディアの記事も、全てGNU Free Documentation Licenseの元に提供されております。

©2026 GRAS Group, Inc.RSS